View Issue Details

IDProjectCategoryLast Update
0018908Starward Rogue[All Projects] Crash/ExceptionFeb 7, 2018 4:21 pm
ReporterkassemmelAssigned Tox4000Bughunter 
Severitycrash 
Status resolvedResolutionfixed 
Product Version1.501 
Fixed in Version2.001 (Die A Fiery Death, Audio Crash) 
Summary0018908: Access Violation
DescriptionFloor 5, entered boss room -> crash
best run, never lucky :(
TagsNo tags attached.

Activities

kassemmel

Sep 13, 2016 6:03 pm

reporter  

2016-09-13_220124.zip (39,077 bytes)

x4000Bughunter

Feb 5, 2018 10:04 am

administrator   ~0046867

Okay, the word I have back from unity on this at the moment is as follows:

----------------

- I have checked the video of the crash in one of your cases, right before the crash, the graphics seems to glitch out.
- A screenshot of R6025 pure virtual function call error makes me think the crash is caused by graphics device drivers.
- All the users who had crashes are using older graphics card driver versions.

For now, could you inform your users who have these crashes to update their graphics card drivers?

If these crashes happen again with new drivers, contact me again and send me the new log files and crash dump files.

x4000Bughunter

Feb 7, 2018 4:21 pm

administrator   ~0046903

* FINALLY fixed the longstanding super-infrequent crashing that was happening for some-but-not-all players. This has been a thorn in our side for two years now, but we finally got some excellent help from Unity's engine developers themselves, and it turns out that we were triggering a crash bug somewhere deep in the engine via calls to WWW.audio.GetAudioClip().
** That's now on their list to investigate and fix, but in our case now that we know what the problem actually is, we've switched approaches to no longer use that method at all, instead baking the music and voice tracks into the game itself.
** We do still have to use this method for the SoundsFromMods optional folder, but that's just for modders who want to add sounds, and it should limit any crashes to on-startup only, not during gameplay. And in those instances it would only be if you're playing with some mods on, and even then only rarely if ever. For everyone currently playing the game that we are aware of, you won't have a crash from this piece. If you have a crash, that would be something else instead.
** Incidentally, the reason that the game was crashing after killing enemies or during room switches is... drumroll... because those are times when music tracks change. We were looking for so many other pieces of code that might be a problem during that time that we never thought to look at music. This is the same music code we've used since 2010 in every other title of ours prior to this one, so whatever the problem is with the underlying engine is must have been introduced in Unity 5 or thereabouts.

Issue History

Date Modified Username Field Change
Sep 13, 2016 6:03 pm kassemmel New Issue
Sep 13, 2016 6:03 pm kassemmel File Added: 2016-09-13_220124.zip
Dec 20, 2016 9:31 pm Dominus Arbitrationis Assigned To => keith.lamothe
Dec 20, 2016 9:31 pm Dominus Arbitrationis Status new => assigned
Feb 5, 2018 10:04 am x4000Bughunter Note Added: 0046867
Feb 7, 2018 4:21 pm x4000Bughunter Assigned To keith.lamothe => x4000Bughunter
Feb 7, 2018 4:21 pm x4000Bughunter Status assigned => resolved
Feb 7, 2018 4:21 pm x4000Bughunter Resolution open => fixed
Feb 7, 2018 4:21 pm x4000Bughunter Fixed in Version => 2.001 (Die A Fiery Death, Audio Crash)
Feb 7, 2018 4:21 pm x4000Bughunter Note Added: 0046903